Amcrest DVR email trigger does not include attachment

I upgraded my security camera system from standard definition (960 x 480) to 4 MP (2560 x 1440). I had to change my original cables to a Siamese RG59 style, which I had to run again inside the attic, a process I wish not to repeat if I upgrade to 8MP (4K).

I got an Amcrest AMDV4M4-S5 DVR which stores HD footage from analog cameras. Excellent quality nonetheless. Found an issue that many are having, of triggering email attachments when motion is detected, which were not including attachments at all.

Following the standard procedure found on amcrest forums yielded no results. I had to perform trial and error steps within the main device, and this is what I found:

  1. Ensure that Motion Detect is enabled, to send email, and snapshot. You need to enable it for each Channel.
  2. Ensure that Recording is enabled under storage for both Main Stream and Snapshot.
  3. This one is the kicker. Under Storage, Schedule and Snapshot tab, ensure that MD has been marked (yellow) for all days.

You can see the 3 pictures below.

Ensure that Motion Detect is enabled, to send email, and snapshot. You need to enable it for each Channel.
Motion Detection Enabled
Ensure that Recording is enabled under storage for both Main Stream and Snapshot.
Recording enabled
This one is the kicker. Under Storage, Schedule and Snapshot tab, ensure that MD has been marked (yellow) for all days.
Snapshot Recording

Hope this helps fixing the email triggering with snapshot issue.

Share